
Project Timeline Template
    In this topic

You can create a project timeline 

· From an existing data file in Microsoft Project Exchange (.mpx), Microsoft Excel (.xls), or comma- or 
tab-delimited text (.txt) format.

· By entering task, duration, dependency, and resource information into rows in a project frame. 

You can put more than one timeline on the same drawing page and dates in project timescales can fall 
between 1984 to 2030.

You can also export a timeline as a Microsoft Project Exchange (.mpx) file so that you can open and work 
on it in Microsoft Project.

Generating a timeline from an existing data file
You can run the Project Timeline Wizard to convert an existing data file into a Visio project timeline. For 
details about how to set up a data file, see Project Timeline Wizard Template.

To run the Project Timeline Wizard:

· Choose File > New > Business Diagram > Project Timeline Wizard.

Visio places a project frame on the drawing page that includes Task Name, Start Date, End Date, and 
Duration columns, a row and task bar for each task, and a timescale that begins with the date you 
choose in the wizard or Project Timeline Options dialog box. If your data file includes additional data 
(such as Resource Name), the data is preserved and you can display it in the timeline by adding more 
columns.

Tip: You can also run the wizard by opening the Project Timeline Template and dragging the Project 
Frame shape to the drawing page. 

Creating a timeline by entering task information
You can create a project timeline by entering data into rows in a project frame.

To prepare the project frame:

1. In Visio, choose File > New > Business Diagram > Project Timeline.

2. Drag the Project Frame shape to the drawing page. When prompted, choose Yes to start the Project 
Timeline Wizard or No to open the Project Timeline Options dialog box.

Run the wizard to customize the appearance of your timeline by choosing the color of the task bars 
and milestones, the line ends for summary tasks, and more.

Open the Project Timeline Options dialog box to quickly create a project timeline with a default 
appearance. You can later change the way the timeline looks on the drawing page.

3. In the wizard or Project Timeline Options dialog box, choose the start date for your project and the 
number of tasks the project will include (you can add or delete tasks later if necessary).

Visio places a project frame on the drawing page that includes Task Name, Start Date, End Date, and 
Duration columns, a row and task bar for each task, and a timescale that begins with the date you 
choose in the wizard or Project Timeline Options dialog box.

Revising a timeline
After you've generated a timeline from a data file or prepared a project frame, you can revise and format 
the timeline. For example, you can



· Change task names.

· Change the start and end dates or the duration of tasks.

· Add new tasks or re-order or delete existing tasks.

· Add milestones.

· Set dependencies between tasks.

· Add "percent complete" indicators to task bars.

· Create summary tasks.

· Change the dates or units that display in the timescale.

· Scroll the timescale by date or to display a particular task bar or milestone.

· Set the non-working days.

· Add additional data to the timeline by adding columns to the project frame.

· Change the appearance of the timeline.

Changing task names
You can quickly change the name of any task listed in the Task Name column in the project timeline.

To change a task name:

· Click the cell that contains the name you want to change, then type the new name.

Changing task start and end dates or durations
You can change task dates and durations by typing new dates or durations in the appropriate columns of 
the timeline or by dragging a task bar shape. Start and end dates must fall between 1975 and 2035.

To type a new start date, end date, or duration:

· Click the cell that contains the date or duration, then type the new date or duration. For duration, use 
the following abbreviations: m for minutes, h for hours, d for days, w for weeks.

The task bar changes length in response.

To drag a task bar:

· Click the task bar to select it, then drag the green selection handle until the bar is the length you want.

The dates in the Start Date, End Date, and Duration columns change in response.

Adding, re-ordering, or deleting tasks
You can add or delete tasks to a timeline at any time. You can also re-order existing tasks.

To insert a task between two existing tasks:

· Drop a task bar or milestone shape onto the timescale portion of the timeline between the two tasks 
you want the new task to follow and precede.

Visio inserts a row into the project timeline.

Tip: You can also insert a row by right-clicking any cell in a row, then choosing Insert Row from the 
shortcut menu. The new row appears before the row you right-clicked.

To add tasks at the end of the timeline:

· Select the project frame by clicking the solid line surrounding the entire timeline, then drag the bottom 



selection handle.

As you drag, you add rows to the bottom of the project frame.

To delete a task:

· Right-click any cell in the row that contains the task you want to delete, then choose Delete Row from 
the shortcut menu.

To change the order of a task:

· Select the Task Name cell of the task you want to re-order, then drag the task to the new location.

The task name, data, and bar move to a new location but the task ID numbers don't change.

Adding milestones
A milestone is a task with a duration of zero days. You can convert any task bar to a milestone by setting 
the task duration to zero. You can convert a milestone shape to a task bar by setting a duration greater 
than zero.

To add a new milestone to a project timeline:

· Drop a Milestone shape from the Project Timeline stencil on the timeline between the tasks you want 
the milestone to precede and follow.

Visio adds a row to the timeline that includes an ID, Task Name, other data fields, and a milestone 
shape.

To make any existing task a milestone:

· Type a duration of 0 (zero) in the Duration column of the project timeline.

Tip: You can also convert an existing task bar to a milestone by dragging the right side selection handle 
on top of the other.

Changing the dependencies between tasks
When you generate a timeline using the wizard or by preparing a project frame, the tasks are not 
dependent on one another. You can quickly create dependencies between tasks and you can eliminate 
dependencies once you've created them.

To create dependencies between tasks:

1. Select the task bars and milestones between which you want to create dependencies. To select 
multiple tasks, hold down the Shift key while you select.

2. Right-click one of the selected shapes, then choose Link Tasks from the shortcut menu.

Tip: You can also link selected tasks by clicking the Link Tasks  toolbar button, and you can link all 
tasks in a project by choosing Project > Link All Tasks.

To eliminate dependencies between tasks:

1. Select the task bars and milestones with dependencies you want to eliminate.

2. Right-click one of the selected shapes, then choose Unlink Tasks from the shortcut menu.

Tip: You can also unlink selected tasks by clicking the Unlink Tasks  toolbar button.

Creating summary tasks
Your timeline can include summary tasks. A summary task encompasses more than one subordinate task.
For example, you might want to include a summary task called Creating Documentation that would 



include the subordinate tasks of writing, editing, and production.

To create a summary task:

1. Add the summary task and all the subordinate tasks to the project timeline. Make sure the summary 
task is directly above the first subordinate task.

2. Select the subordinate tasks, then choose Project > Demote Tasks.

Visio adds line ends to the summary task bar and extends it to encompass the duration of the 
subordinate tasks. The summary task text turns bold.

Tip: You can also demote selected tasks by clicking the Demote Tasks  toolbar button.

To promote subordinate tasks:

· Select the tasks you want to promote, then choose Project > Promote Tasks.

Tip: You can also promote selected tasks by clicking the Promote Tasks  toolbar button.

Adding percent complete indicators to task bars
By adding a Percent Complete data column to your timeline and typing percentages in the column, you 
add percent complete indicators to task bars. You can control the size of the indicators and whether or not
they display on the bars.

Tip: You can also display a percent complete indicator on any task bar by dragging the task bar's control 
handle.

To add percent complete indicators:

1. Select the column to the left of where you want the percent complete column to appear.

2. Choose Project > Insert Column.

3. In the Insert Column dialog box, under Column Type, choose Percent Complete, then click OK.

Visio adds Percent Complete to the timeline. When you type a percentage in a cell in the new column, 
an indicator appears in the task bar.

To change the size of the percent complete indicators:

1. Right-click the drawing page with no shapes selected, then choose Configure Task Bar Sizes.

2. Under Normal Task Bar Percent Complete Height and Summary Task Bar Percent Complete Height, 
type the size you want, then click OK.

Changing the timescale display
By default, the timescale starts with the date your project begins (that is, the date you entered in the 
wizard or the Project Timeline Options dialog box) and it displays Days and Months. You can extend the 
project frame to see more dates at a time, change the initial date in the timescale, and change the 
timescale units.

To extend the timescale and display more dates:

· Select the entire project timeline by clicking the solid line that surrounds the project frame, then drag 
the right-center selection handle.

The project frame extends and more dates appear in the timescale.

To change timescale units:



· Choose Project > Change Timeline Units, then choose the units you want.

Tip: You can also change timescale units by right-clicking the timescale, then choosing the units you 
want from the shortcut menu.

To change the date range the timescale displays:

1. Choose Project > View Timeline Range.

2. In the View Timeline Range dialog box, enter the first and last dates you want displayed on the 
timescale.

When you choose the dates to display, remember that the project frame won't change in size in 
reponse to the dates you type. If the new date range is longer than the original range, the timescale 
units will change so the longer range can be displayed. For example, if your original range is June 2 - 
June 24 and you change the dates to June 1 - July 15, the timescale will change from Days/Months to 
Months/Years to accommodate the longer range.

Scrolling the timescale
To scroll the timescale to display earlier or later dates:

· Click the View Previous Date toolbar button to scroll one unit (day, month, or quarter, depending upon 
the units you set for the timescale) earlier.

· Click the View Start Date toolbar button to scroll to the date on which the first task starts.

· Click the View Next Date toolbar button to scroll one unit (day, month, or quarter, depending upon the 
units you set for the timescale) later.

· Click the View End Date toolbar button to scroll to the date on which the last task ends.

Tip: You can also scroll earlier and later by right-clicking the timescale, then choosing the appropriate 
View < > command from the shortcut menu.

To scroll the timescale to display a particular task bar or milestone:

· Right-click any text entry cell for or the horizontal grid line below the task you want to display, then 
choose Show Task Bar.

Setting the non-working days
Task bars extend across non-working days, but task durations don't take non-working days into account. 
By default, non-working days are Saturday and Sunday, but you can designate other non-working days 
for your project. 

For example, assume June 4 and 5 are non-working days. A three-day task that begins on June 2 has an 
end date of June 6. On the timeline, June 4 and 5 are marked by a light-yellow band indicating they are 
non-working days, and the task bar extends from June 2 through June 6.

To set the non-working days:

1. Choose Project > Configure Working Days.

2. Check the days you want to set as non-working.

Tip: You can also set non-working days by right-clicking the timescale, then choosing Configure Working 
Days from the shortcut menu.

Adding and deleting data columns
To include data in addition to start date, end date, and duration in your timeline, you can add columns. 
When you add a column, Visio prompts you for the type of data you want the column to include. You can 



choose from a list of data types (such as Percent Complete or Resource Name), or you can create a 
user-defined text, number, time, or decimal column.

To add a data column:

1. Select the column to the left of where you want the new column to appear.

2. Choose Project > Insert Column.

3. Under Column Type, choose the type of data you want the column to include.

4. Under Column Name, accept the default name or type a new one, then click OK.

Visio adds a new data column to the timeline. If you generated the project timeline from a data file that 
included data of the type the new column represents, the data appears.

Tip: You can also insert a data column by right-clicking the column to the left of where you want the new 
column to appear, then choosing Insert Column from the shortcut menu.

To delete a data column:

1. Select the column you want to delete.

2. Choose Project > Delete Column.

Visio deletes the column from the timeline. If you generated the project timeline from a data file that 
included data of the type in the column, Visio preserves the data and will display it if you add the 
column again in the future.

Tip: You can also delete a data column by right-clicking the column you want to delete, then choosing 
Delete Column from the shortcut menu.

Changing the location of data columns
By default, Visio places data columns to the left of the timescale portion of the project timeline. You can 
move one or more columns to the right of the timescale portion.

To move a data column:

1. Click in the header region of a column to select it.

2. Drag the column to its new location.

Position the column you're moving on top of another column and release the mouse button to place the
repositioned column to the right of the original column. Position any part of the column you're moving in
the timescale region and release the mouse button to have the column appear to the right of the 
timescale.

Changing the appearance of a project timeline
You can change the appearance of task bars, milestones, and dependency arrows in your timeline. 

You can customize one task bar or milestone or choose options that apply to all the bars and milestones 
in the timeline.

You can also turn on or off vertical and horizontal grid lines.

To change the appearance of dependency arrows:

· Right-click the page, then choose Set To L Connectors or Set To S Connectors. The command you see
depends upon the current setting.

To customize the appearance of one task bar or milestone:

1. Right-click the shape you want to customize, then choose Configure Tasks or Configure Task Bar Text 



from the shortcut menu.

2. Choose the options you want, then click OK.

To customize the appearance of all task bars and milestones:

1. Right-click the drawing page with no shapes selected, then choose Configure Overall Layout, 
Configure Task Bar Text, or Configure Timeline Symbols from the shortcut menu.

2. Click tabs to choose the options you want for task bars, milestones, and summary bars, then click OK.

Note: Page settings do not override the individual settings of customized individual task bar or milestone 
shapes. To change a single shape's settings to the page settings, right-click the shape, choose the 
appropriate Configure command, choose Default for the settings you want to change, then click OK.

To resize all task bars and milestones:

1. Right-click the drawing page with no shapes selected, then choose Configure Task Bar Sizes from the 
shortcut menu.

2. Type the task bar, summary task bar, symbol, and percent complete indicator sizes you want, then click
OK.

To turn on or off grid lines:

· Right-click the drawing page with no shapes selected, then uncheck Vertical or Horizontal Lines to hide
the lines, or check Vertical or Horizontal Lines to display the lines.

Exporting a project timeline
You can export a timeline as a Microsoft Project exchange (.mpx) file so you can open and work on it in 
Microsoft Project.

To export a project timeline:

1. Open the project timeline you want to export.

2. From the Project menu, choose Export Project.

3. In the Save As dialog box, type a name for the file, choose a location, then click Save.

Printing a project timeline
Most project timelines are too large to print on one regular-sized printer page, so your project timeline is 
likely to print, or tile, across several pages. Before you print

· Make sure the printer page and drawing page orientations are the same. Choose File > Page Setup, 
then click the Page Size tab to check the drawing page orientation. Click Printer Setup on the Page 
Size tab to check the printer page orientation.

· Turn on Page Breaks so you can see how many pages the timeline will print on and where the page 
breaks fall. To turn Page Breaks on, choose View > Page Breaks.

· Set your margins to control the overlap between printed pages. Visio does not crop drawings to fit 
within the margins, so the larger the margins, the larger the portion of the timeline that prints on 
adjoining pages. To set margins, choose File > Page Setup, click the Page Size tab, then click Printer 
Setup.

· Preview how the drawing will print before you print it. To preview, choose File > Print Preview.

For details about printing in Visio, see About printing drawings.
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